#853 – Route 66 1.9.4 messed up my menu system somehow

Status: Closed - Category: Route 66
Hello,

I'm not really looking for any help because I've figured it out, I just want to let the developers know about this issue.

So after upgrading Route 66 from 1.9.3 to 1.9.4 my menu system got messed up. When I opened my website it opened my hidden menu home page instead of my main (default) home page.

After disabling Route 66 plugin everything went back to normal. Then I reinstalled Route 66 1.9.3 version and it works fine again. So there seems to be an issue with 1.9.4 version that caused this problem. So I'll be staying on 1.9.3 for now.

Just wanted to let you know about this. Btw, I'm using Joomla 4 (4.1.0).

Regards,
Kristjan
Hi Kristjan,

Just tested under a mulit-language Joomla 4.1 site without issues.
Can you please provide more details about your setup?

Regards
 
Hi,

there's really not much more I can tell you about it. It's Joomla 4.1.0, I use YooTheme Pro as a template.

And even though there is a possibility that some other plugin was causing the issue, everything worked fine with the Route 66 1.9.3 version, the problems started with 1.9.4 and went away as soon as I disabled Route 66. After that I tried going back to 1.9.3 and everything works again.

I also use Akeeba Admin Tools and I've had some issues with it in the past with some plugins, but since it works fine with Route 66 1.9.3 version, I'm not sure why there would suddenly be a problem with 1.9.4.

Unfortunately I'm not an expert in coding or anything like that, I just know enough to build a website in Joomla. So I'm not sure what else I could tell you. I just know that everything else being the same, Route 66 1.9.4 caused the problem but everything works fine with 1.9.3, nothing else was changed in between.

Regards
Hi Kristjan,

Can you please try the development version and let me know? You can download it from https://www.dropbox.com/s/hjylj4tp8macclz/pkg_route66-master.zip?dl=1

Regards
 
Hello,
so I tried the development version and the same thing happened - when I opened the website it opened a blank page, the hidden menu home version which has nothing on it. I know that because of the title in the browser tab.
Then I reinstalled 1.9.3 and everything went back to normal.
Regards
Since I seem to be the only one having this issue (at least I can't find any information that others do), it's probably a combination of Route 66 and some other plugin that I'm using that causes this to happen.

I don't really want to waste too much time on this since version 1.9.3 is working fine, but I could try again with 1.9.4 and disable other plugins to see what happens and then enable them back one by one to see which one causes the issue.

But again, 1.9.3 is working fine, so I don't really want to be wasting too much time on this.
Ok, so I had some time now so I actually tried - I disabled all the extensions and plugins that I use (with the exception of the template - YooTheme Pro) and nothing changed. Route 66 1.9.4 is just not working. As soon as I went back to 1.9.3 everything works fine.

So I guess it's either something with YooTheme Pro or some Joomla setting, or it's Route 66 itself, but since you tested it out yourself that's probably not the case, which leaves YooTheme Pro or some Joomla setting that I changed and is causing the problem.
Hi Kristjan,

I need access to your website in order to troubleshoot this. If this is possible, please create a new private ticket and provide administrator credentials so I can have a look.

Regards
 
I will open a private ticket but I need to do some work on the website first so I need everything to work properly. After that I will provide you the login info.

Btw, I tried the 1.9.5 version of Route 66 and the problem didn't go away, so I'm sticking with 1.9.3 for now.

Regards
I made another discovery. I updated to the latest version of Route 66, version 1.9.5 and then tried disabling parts of the extension one by one. I found out that the one causing problems is System - Route 66. If I disable this one and leave the rest of them enabled, everything works fine. As soon as I enable System - Route 66, the issue comes back. Of course that means I can't use customized URLs, but I'm using Joomla's built in functions for making URLs search engine friendly. So the only function of Route 66 that I keep using is the article SEO, that comes in pretty handy.
New update - the newest Joomla update 4.1.3 that just came out fixed all the problems I had.
This ticket is closed, therefore read-only. You can no longer reply to it. If you need to provide more information, please open a new ticket and mention this ticket's number.

Note: An active subscription is required in order to get support for our paid extensions. For our free extensions, if you don't have an account, register and then submit your support request.  In case you just want to ask a question, you can also use the contact form .

Firecoders
Are you using our extensions? Please post a review at the Joomla extensions directory!
Post a review