#269 – Sitemaps return 404 error

Status: Closed - Category: Route 66
Hi.
I installed route66 last night and after I created a sitemap, I tried to test it. On clicking the preview button I just get a 404 error.
The link generated for the sitemap is https://teflph.com/e66/sitemapindex/1?format=xml I notice in the file structure of the website there is no directory "e66" that has been created.

Any help would be apreasiated.

Regards, Brendan
Hi,

You are right there is an issue when we are generating the preview link in the administration area. We have fixed this already for the next update.
If you do not want to wait just edit the file administrator/components/com_route66/models/sitemaps.php and replace line 81 with the following:
$link = JUri::root(false).substr($link, strlen(JUri::root(true)) + 1);


Let me know if that solves your issue.

Regards
 
Hi,
Thanks for the quick reply.

Your solution worked as far as resolving the 404 error.
However I notice these points that are still in error.

The URL generated for the sitemap withing the sitemap is non existent....

<sitemapindex xmlns="http://www.sitemaps.org/schemas/sitemap/0.9">
<sitemap>
<loc>
https://teflph.com/component/route66/sitemap/1/content?format=xml
</loc>
</sitemap>
<sitemap>
<loc>
https://teflph.com/component/route66/sitemap/1/menus?format=xml
</loc>
</sitemap>
</sitemapindex>

In my site directory there are no folders component, route66, sitemap or 1

I would also say that the above sitemap code that has been generated from the preview button is lacking most of the sites info.

Have you any other ideas?

Regards, Brendan
First, do not look for subfolders, this is not the way it's working. Joomla works with URL rewrites.
Now to the point, I cannot verify the second issue you are reporting. Please create a new private ticket and provide administrator credentials so I can take a look.

Regards
 
Hi,
Sorry for the delay.
I wonder if the sitemap issue is due to HTTPS? Does the free version of route 66 crawl https links as well as old ones?

I ask because I have come across some sitemap generators that will only crawl http in their free versions.

Regards, Brendan
Not sure about it. If your site runs on HTTPS you may want to enable the "Force HTTPS" option in Joomla global configuration.

If that doesn't solve the issue please create a new private ticket and include administrator and FTP credentials so I can have a look.

Regards
 
This ticket is closed, therefore read-only. You can no longer reply to it. If you need to provide more information, please open a new ticket and mention this ticket's number.

 

Note: An active subscription is required in order to get support for our paid extensions. For our free extensions, if you don't have an account, register and then submit your support request.  In case you just want to ask a question, you can also use the contact form .

Firecoders
Are you using our extensions? Please post a review at the Joomla extensions directory!
Post a review
Follow us in Facebook to get the latest news and updates about our extensions!
Facebook
Follow us in Twitter to get the latest news and updates about our extensions!
Twitter